Ir al contenido principal

Entradas

Mostrando entradas de agosto, 2007

Mi proyecto actual

Mi proyecto actual es una distribucion modificada de debian para appliances. Con imagen corporativa integrada desde el booteo hasta el inicio del sistema GNU.
De esta sacare derivados que son appliances virtuales que corren en VMware con usos especificos, como firewall , sistema de proteccion de correo etc.

Bueno esta es mi ultima actualiacion de este proyecto.
Esto rogreoso muy bien al unto que tenia todo el sistema de booteo grafico perfecto y muy bueno, pero por cosas del destino, la persona y el objetivo que tenia se perdieron y asi mismo mi entusiasmo con esto. El proyecto se congelo.

Resuelto el problema de la e1

Por fin resolvi el problema de la e1 con la rhino dual.
Lo que hice fue crear estos dos archivos:

zaptel.conf
====================
span=1,1,0,ccs,hdb3
bchan=1-15
dchan=16
bchan=17-31

span=2,1,0,ccs,hdb3
bchan=32-46
dchan=47
bchan=48-62

# Global data
loadzone = us
defaultzone = us

Y ahora el zapata.conf


; Zapata telephony interface
;
; Configuration file

[trunkgroups]

[channels]
group=>1
context=>from-zaptel
signalling=>pri_cpe
language=es-co
;rxwink=300 ; Atlas seems to use long (250ms) winks
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes
usecallerid=yes
hidecallerid=no
callwaiting=no
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=256
rxgain=0.0
txgain=0.0
channel=>1-15,17-46,48-62

faxdetect=both
;faxdetect=incoming
;faxdetect=outgoing
;faxdetect=no

;Include genzaptelconf configs
#include zapata-auto.conf

;Include AMP configs
#include zapata_additional.conf



Conexion en corto

Que tal la perla. Como es que un dia Lunes (como siempre un Lunes). Amanece la red corporativa abajo 6 sedes en una wan corporativa, todo interconectado por un bus de fibra optica y/o ethernet y todo totalmente abajo.
Pues bien revisando en 3 locaciones que estan interconectadas via ethernet encontramos que extrañamente separandolas los switches volvian a funcionar normalmente (switches 3com) excepto una sede y era la que recibia 2 locaciones y los enlaces de internet 1 de esas 2 locaciones no se habia desconectado ni los enlaces.... luego apenas desconectamos los enlaces de internet no paso nada....pero cuando desconectamos la ultima locacion el switche volvio a la normalidad asi que corra para esa ultima locacion e inspeccionando visualmente encontramos que tenian una conexion en loop... a algun gracioso le dio por conectar un cable de red en loop!!!
Por mi que lo pongan en la cancha de paintball y lo fusilen.

Actualizacion problema freepbx

Continuando con el dichso problema.
Elimine todos los modulos de zaptel que no corresponden al hardware de la maquina y deje solmente el rxt1 que es el que maneja la tarjeta instalada la rhino r2t1.
Adicionalmente puse la siguiente configuracion en zaptel.conf
span=1,1,0,ccs,hdb3
bchan=1-15
dchan=16
bchan=17-31

span=2,1,0,ccs,hdb3
bchan=32-46
dchan=47
bchan=48-62

Y las siguiente entradas en zapata.conf
signalling=pri_cpe
switchtype=national
group=1
switchtype=euroisdn
signalling=pri_cpe
channel => 1-15,17-31
ademas de las referenciadas en voip-info.org

En modprobe.conf coloque la siguiente entrada para asegurarme que la tarjeta esta en modo e1, apesar de que ya tiene el jumper:
option rxt1 e1t1override=3

Con esta configuracion por fin detecto donde estaba pegado el cable del e1 y lo puso en estado ok. Sin embargo no estaban entrando ni saliendo las llamadas, apesar de tener configurado el trunk para el canal zap/g1 y una ruta de entrada any/any

Este chicharron continuara

Problema free pbx

En estos dias estoy tratando de migrar un applianca de trixbox 2.2.0rc3 a la 2.2.3 estable.
El primero con una tarjeta digium con una e1 y el segundo una rhino dual e1.
Al principio migramos con un backup full atravez del modulo de free pbx. El problema fue que en la segunda caja al restaurarlo este sobrescribe el free pbx con la version del otro, y el formato de configuracion de asterisk hace conflicto ni siquiera haciendo despues un update se logro que cojiera la configuracion anterior.
Solucion: configuracion desde 0, se realizo otra vez la configuracion desde 0 en la segunda caja (la rhino).
Problemas: Aunque zaptel y sus modulo reconocen la tarjeta rhino, aun no he podido hacer que entren llamadas.
Estare actualizando con el progreso de este.